
 

 

1/14 

© 2017 ROHM Co., Ltd. No. 60AP001E Rev.001 

2017.4 

© 2018 ROHM Co., Ltd. No. 61UG032E Rev.001 

Nov.2018 
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RAGU V1.0 

The RAGU is Evaluation Tool controls the stepping motor driver IC to demonstrate and evaluate its functions:  

  

1. Speed control (by variable clock frequency)  

2. Spin direction control (Clockwise or counter-clockwise)  

3. Power Save  

4. Excitation modes  

5. Current decay control  

6. Output current control  

7. Junction temperature measurement (by TEST pin diode)  

8. Efficiency measurement (Icc vs Iout)  

  

This system is composed of Software and Hardware parts. The Software runs in a PC with a USB port, and communicates with the hardware. The 

Hardware is composed of 2 major parts, RAGU main board (RAGU-main1-EVK-001) and RAGU option board (RAGU-op1-EVK-001). RAGU 

main board generates the signals to control the DUT (Device under test). RAGU option board allows oscilloscope feature and monitors output 

voltages and currents. 
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I. Introduction 

 

What is RAGU V1.0? 

 

It is a user friendly evaluation tool that enables to demonstrate 

and evaluate the function of stepping motor driver IC’s. 

 

What Can We Do with this Tool? 

This tool enables the user to evaluate or demonstrate certain 

functions of motor driver IC’s without the use of bulky 

instruments (e.g. oscilloscope, power supply). 

With its Software and Hardware, the user can rotate stepping 

motors, adjust current limit, control current decay, change 

excitation mode, and monitor waveform of output voltages and 

currents. 

 

Figure 1. RAGU tool screen 

 

II. Software Requirements 

Materials and specifications needed to operate the application. 

Hardware Requirements  

RAGU main board (RAGU-main1-EVK-001) 

RAGU option board (RAGU-op1-EVK-001)  

USB Cable Mini B  

Wall adapter 

RAGU board with DUT 

 

 

Computer Requirements  

Windows 10 32bit  

User account with administrative privileges  

Minimum screen resolution of 1024 x 768  

 

Software Requirements  

Cypress Drivers*1  

FPGA’s Raw Binary File*1  

※1…Installer package includes these items. 

 

 

III. Software Installation 

This section explains how the installer package is used to 

install the application into your computer. 

Software Installation 

 

 
Figure 2. Icon of Installation

 

 

Locate and run the installer. Step 

1 
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Figure 3. Setup Screen 1 

 

 

 

 

Figure 4. Setup Screen 2 

 

 

Figure 5. Setup Screen 3 

 

 

 

Figure 6. Setup Screen 4 

 

The setup wizard will appear. Click Next to 

continue. Step 

2 

 

To confirm the installer’s Terms of Agreement, 

click I Agree. Step 

3 

 

Choose your preferred options and click Next. Step 

4 

 

Click Browse to change the installation directory 

otherwise the default directory will be used. Click Install 

to proceed. It is highly recommended that the 

application be installed in a directory or computer that 

         has administrative rights. 
Step 

5 
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Figure 7. Setup Screen 5 

 

 

 

 

 

Figure 8. RAGU shortcut 

 
 

  

Notice that there are shortcuts of the application in the 

desktop and start menu. (Note: You have the option to   

         select where to add/or not to add shortcuts.) Step 

7 

 

Click Finish to close the wizard. Step 

6 
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IV. System Setup 

General Setup 

 

Figure 9. General Setup 

 

                                     

 

 

 

 

 

 

 

 

 

Figure 10. Hardware parts 

 

 

Component Descriptions 

 

Motor Stepping 

Connectors 

USB 2.0 
(that is connected to PC) 

AC adapter 

Ribbon wire with connectors 

RAGU DUT board CLK-IN type 

RAGU main board RAGU-main1-EVK-001 

RAGU option board RAGU-op1-EVK-001 

Table 1. Hardware parts 

 

V. Function 

This section discusses the different function available for the 

RAGU software. 

 

Basic Drive 

This is the basic function is included by default on the software. 

It allows the user to use the basic drive features located on the 

left side of the control software. 

 

Figure 11. RAGU at startup 

 

Dynamic Mode 

This license allows the user to access the Dynamic Mode 

window. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 12. Dynamic Mode 

  

 

Stepping Motor AC adaptor 

Connecting cable 

RAGU DUT board 

RAGU main board RAGU option board 
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Oscilloscope 

This license allows the user to use the built-in oscilloscope 

which features 4 input channels and triggering feature. 

Also the oscilloscope’s calibration feature may be used. 

*Note: In order use this feature, RAGU-op1-EVK-001 is 

necessary. 

 

Figure 13. Oscilloscope at startup 

 

Thermometer 

This license allows the user to monitor the DUT’s temperature 

via the thermometer control and also allow access to the Tj 

Monitor window. 

*Note: In order use this feature, RAGU-op1-EVK-001 in 

necessary. 

 

 

 

 

 

Figure 14. DUT temperature measurement tools 

 

 

VI. Parts of the Control Software  

Main GUI 

 

Figure 15. Main GUI 

 

(01)ON Switch 
Switch that enables access to 
RAGU 

(02)DUT Control Settings 
Input control signal of DUT 
(Motor Driver IC) 

(03)Graph/Plot Area Graphs measured values 

(04)Oscilloscope Settings Oscilloscope like settings 

Table 2. Main GUI Common Controls 

 

 

DUT Control Settings 

 

Figure 16. DUT Control Settings  
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(01) Operating Mode -Switch that enables access to 
RAGU 

(02) Levels  

(a) Voltage Level -Value can be changed by either 
the slider or text box. 
-To move from one text box to 
another, use the enter key. 
-The sliders can be configured 
using the MAX, STEP and MIN 
text boxes. 

(b) Frequency Level -Value can be changed by either 
the slider or text box. 
-The CLK slider can be 
configured using the MAX, 
STEP and MIN text boxes. 

(03) Computation -Displays the calculated Io 

(04) Clock Output -Use the Start button to enable 

or disable the clock output. 

-Continuous Mode: Clock 
outputs until the Stop button is 

clicked. 

-Manual Mode: Clock 

generates specified number of 
clock cycles. 

(05) Pin Voltage Levels -Use the choices to select the 
voltage levels of the 
corresponding pins. 

Table 3. Main GUI Common Controls 

 

 

Graph/Plot Area and Oscilloscope Settings 

 

Figure 17. Oscilloscope Settings 

 

 

 

(01)Graph/Plot Area  

(a) Time-Delta 
Measurement 

-Use the right double click to 
ON/OFF, use right single click 
to move the blue cursor. Time 
is measured between the red 
(left click) and blue (right 
click) cursors. 

(b) Time-Value 
Display 

-Use the left double click to 
ON/OFF, use left single click 
to move the cursor 

(c) Horizontal Scroll -Use the Left and Right Arrow 
Buttons to scroll through the 
waveform 

(02)Channel 
Settings 

 

(a) On/Off -Show/hide the specified 
channel 

(b) Source -Select measurement source 
(Output Voltage/Current/ICC) 

(c) Output -Channel Select (A/B) 

(d) Value/Div -Display the current or 
voltage value/Div of each 
channel 

(e) Range -Change the VALUE/Div 
Settings 

(f) Setup -Open the Channel Settings 
window 

(g) Sec/Div -Control the TIME/Div setting 
of the display (in seconds) 

(h) Sampling Rate -Control the sampling 
frequency of the Waveform 
Scope 

(03)Sampling Rate  

(a) Trigger -ON/OFF triggering 

(b) Channel -Select Channel 

(c) Current -Vary current input level 

(d) Voltage -Vary input voltage level 

(e) Run/Stop -Enable/Disable triggering 
-Continuously read the 4 
channels and plot them in 
chart. Only the current 
available data in the RAM (8k 
samples) will be displayed at 
any time. 

(f) Save -Export graph as image 
(jpeg.) 

Note: Only one slider is active at any time. The active 

slider will depend on the input type (Voltage/Current)  
of the currently selected channel. 

Table 4. Main GUI Common Controls 
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Dynamic Window 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 18. DUT Control Settings 1 

 

Accessed via: View -> Dynamic Window Menu Item 

 The Dynamic Settings window allows the 
user to preprogram a sequence of 
configurations to the device. 

 The Run Cycle determines the repeat count 
for the whole sequence. 

 The repeat delay defines the time between 
each cycle. 

 Press Start to begin the dynamic sequence. 

 

 

 

Temperature Monitor 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 19. DUT Control Settings 2 

Accessed via: View -> Tj Monitor Menu Item 

 The Temperature Monitor window allows the 
user to preprogram a sequence of 
configurations to the device in order to 
monitor the temperature at each setting. 

 At the end of the sequence, the logged 
temperature data is plotted into a Microsoft 
Excel Spreadsheet. 

 Press “Start” to begin temperature 

monitoring. 

 Press “Save Chart” to plot the existing 

temperature log in a spreadsheet. 

 

 

Calibrate 

 

Figure 20. Calibration Settings 

 

The calibrate function is found under the Help Menu. 

 Note: Ensure that all oscilloscope functions are 
turned off before calibrating the device. Calibrating 
the device while using the oscilloscope may result to 
an incorrect calibration. 
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VII. Using the Application and Its Tools 

How to Use the Scope 

 

Figure 21. Oscilloscope at startup 

 

 

 

How to Use Dynamic Mode 

 

 

 

 

 

 

 

 

 

 

 

Figure 22. Dynamic mode setting screen 

 

 

  
Set desired drive settings. Step 

1 

Ensure that scope is running. Step 

2 

 
The captured waveforms will be displayed. Step 

3 

 
User may use the other scope features such as: Channel 

settings, Trigger & Cursor Measurement 

See Parts of the Control Software > Graph/Plot Area 

 and Oscilloscope Settings. 

* 

Click Start when ready, Stop to cancel, Step 

3 

 

Set the cycle settings. Step 

2 

 

User may also choose to load and save settings 

via the File menu. 

* 

Input desired values in grid: 

 
Time 

Time when row of settings 
will be implemented 

VREF Value in x.xx format 

MTH Value in x.xx format 

CLK Value in hertz [Hz] 

PS Value is either 1/0(H/L) 

ENABLE Value is either 1/0(H/L) 

MODE0 Value is either 1/0(H/L) 

MODE1 Value is either 1/0(H/L) 

CW/CCW Value is either 1/0(H/L) 

User may select multiple cells to 

copy/delete/paste for easy use. 

User may also copy cells from MS Excel and 

paste here. 

Step 

1 
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VIII. Driver Installation 

Drivers are used to detect a device, by checking its firmware 

 

CyUSB Driver Installation Guide  

for Windows 10 32bit 

1. Search for “Device Manager” or “devmgmt.msc”. Open the 

application. 

2. Attach the USB device. 

 

 

Figure 23. Driver installation screen 1 

 

 

Figure 24. Driver installation screen 2 

 

 

 

Figure 25. Driver installation screen 3 

 

 

 

 

 

  

Under Universal Serial Bus controllers, select the USB 

device. Right click the device then press Update Driver 

Software… 

Step 

1 

 

Select Browse my computer for driver 

software. Step 

2 

 

Click Browse… and locate the directory where 

RAGU V1.0 is installed. Click Next. Step 

3 
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Figure 26. Driver installation screen 4 

 

 

 

Figure 27. Driver installation screen 5 

 

 

  

Select Install this driver software anyway. Step 

4 

 

The window will display that the driver has been 

successfully updated. 
Step 

5 
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IX. Software Uninstallation 

Please note that the uninstaller is only capable of removing 

files from the specified installed directory, and. not the files that 

have been transferred to another directory (as for reasons of 

the user). 

 
Figure 28. Uninstall screen 1 

 

 

 

 

 
Figure 29. Uninstall screen 2 

 
 

 

Figure 30. Uninstall screen 3 

 

 

 

 

 

 

 

Locate and run the Uninstall.exe from the 

start menu. Step 

1 

 

Click OK to proceed. Step 

2 

 

Click Next to proceed. Step 

3 
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Figure 31. Uninstall screen 4 

 
 

 

Figure 32. Uninstall screen 5 

 

 

 

 
Figure 33. Uninstall screen 6 

 

Click Uninstall. Step 

4 

 

Click Finish to close the wizard. Step 

5 

 

The software has been successfully removed. 

Click OK. 
Step 

6 
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Revision History 

Date Revision Changes 

20.Nov.2018 001 New Release 
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Notice

ROHM  Customer Support System 
http://www.rohm.com/contact/

Thank you for your accessing to ROHM product informations.  
More detail product informations and catalogs are available, please contact us. 

N o t e s  

The information contained herein is subject to change without notice. 

Before you use our Products, please contact our sales representative and verify the latest specifica-
tions :

Although ROHM is continuously working to improve product reliability and quality, semicon-
ductors can break down and malfunction due to various factors.
Therefore, in order to prevent personal injury or fire arising from failure, please take safety 
measures such as complying with the derating characteristics, implementing redundant and 
fire prevention designs, and utilizing backups and fail-safe procedures. ROHM shall have no 
responsibility for any damages arising out of the use of our Poducts beyond the rating specified by 
ROHM.

Examples of application circuits, circuit constants and any other information contained herein are 
provided only to illustrate the standard usage and operations of the Products. The peripheral 
conditions must be taken into account when designing circuits for mass production.

The technical information specified herein is intended only to show the typical functions of and 
examples of application circuits for the Products. ROHM does not grant you, explicitly or implicitly, 
any license to use or exercise intellectual property or other rights held by ROHM or any other 
parties. ROHM shall have no responsibility whatsoever for any dispute arising out of the use of 
such technical information.

The Products specified in this document are not designed to be radiation tolerant.

For use of our Products in applications requiring a high degree of reliability (as exemplified  
below), please contact and consult with a ROHM representative : transportation equipment (i.e. 
cars, ships, trains), primary communication equipment, traffic lights, fire/crime prevention, safety 
equipment, medical systems, servers, solar cells, and power transmission systems.

Do not use our Products in applications requiring extremely high reliability, such as aerospace 
equipment, nuclear power control systems, and submarine repeaters.

ROHM shall have no responsibility for any damages or injury arising  from non-compliance with 
the recommended usage conditions and specifications contained herein.

ROHM has used reasonable care to ensur  the accuracy of the information contained  in this 
document. However, ROHM does not warrants that such information is error-free, and ROHM 
shall have no responsibility for any damages arising from any inaccuracy or misprint of such 
information.

Please use the Products in accordance with any applicable environmental laws and regulations, 
such as the RoHS Directive. For more details, including RoHS compatibility, please contact a 
ROHM sales office. ROHM shall have  no responsibility for any damages or losses resulting 
non-compliance with any applicable laws or regulations.

When providing our Products and technologies contained in this document to other countries,  
you must abide by the procedures and provisions stipulated in all applicable export laws and 
regulations, including without limitation the US Export Administration Regulations and the Foreign 
Exchange and Foreign Trade Act.

This document, in part or in whole, may not be reprinted or reproduced without prior consent of 
ROHM.
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